Haybusa Parts and Service Member Support

Author Topic: ecueditor.com for K7- gixxers  (Read 56776 times)

Offline Mike-Nightrider

  • Mad Post Whore
  • ******
  • Posts: 4319
  • Gender: Male
Re: ecueditor.com for K7- gixxers
« Reply #75 on: February 26, 2011, 01:12:19 AM »
Cool vid PetriK  :D :tu:
Dragraceteam NIGHTRIDER
1/8: 5.101s..........1/4: 7.801s
227.7mph Woodbridge/GB 2013

Offline Ra12r

  • Apprentice Post Whore
  • **
  • Posts: 10
Re: ecueditor.com for K7- gixxers
« Reply #76 on: May 08, 2011, 11:13:44 PM »
Maj, how did you 06 to Gen2 ecu conversion work?
I rule by day and by night!!!

Offline Oz Booster

  • Site Donor
  • Mad Post Whore
  • *
  • Posts: 3968
  • aka Maj T
Re: ecueditor.com for K7- gixxers
« Reply #77 on: May 09, 2011, 08:27:43 PM »
cam sensor was giving me issues, i now have an 07 sensor on the way and it may interchange with the early sender as a drop in fit ??
Someone with more late gsxr experiance may be able to confirm this??

so i put the gix loom on my gen 1 busa  using a gen 2 cam cover and sensor , modified crank rotor and it fired up fine, so at least my wiring conversion is good,
only point to check when i get it back on the gix is that the crank signal is suitable
Official Site Donor

Offline Ra12r

  • Apprentice Post Whore
  • **
  • Posts: 10
Re: ecueditor.com for K7- gixxers
« Reply #78 on: May 09, 2011, 09:58:06 PM »
Thanks for the progress report. I am at the point trying to figure out how to get the software potential with the K6 also to be able to use the ecueditor program. I wish the bin files was the only variable when you load them like the RomRaider. One program, but just choose different bins. If it would work with the Gen1 busa ecu, then why not the K6 ecu?

I know the RomRaider and have flashed with it, but the definitions are not as developed..........unless I don't have the most recent?!
I rule by day and by night!!!

Offline Oz Booster

  • Site Donor
  • Mad Post Whore
  • *
  • Posts: 3968
  • aka Maj T
Re: ecueditor.com for K7- gixxers
« Reply #79 on: June 13, 2011, 01:15:29 AM »
Update
07 gix 1000 cam sensor interchanges with the earlier sensors for fit , and gen 1 busa. the gen 2 busa and gix 750/600 of similar age run a different cam sensor , so anyone retrofitting can use the 07 gix 1000 sensor.

The 06 gix loom and 08 busa ecu work good on my gen 1 busa (setup with the gen 2 cam sensor and cover before i realised the gix would have been cheaper and easier)
the same loom and ecu do not work on my gix.
The 07 gix loom and ecu with busa .bin does work on my earlier gix when the cam sensor is fitted

So personally now i would not modify a 06 gix loom to use a busa ecu, to use the busa ecu on a busa get a busa loom .. and to get the same functionality on a gix get the gix ecu and loom and use the busa .bin .
posted similar on the 1000 section .

Official Site Donor

Offline badass1000

  • Post Master
  • *****
  • Posts: 1551
Re: ecueditor.com for K7- gixxers
« Reply #80 on: June 18, 2011, 05:53:06 PM »
cool. 
Thank you for the update.  :tu:

Offline gsx-rboy750

  • Authorized Shop
  • Post Master
  • **
  • Posts: 1721
  • Ok. So sometime I can be a little full of myself.
Re: ecueditor.com for K7- gixxers
« Reply #81 on: October 10, 2011, 11:49:06 AM »
Update
07 gix 1000 cam sensor interchanges with the earlier sensors for fit , and gen 1 busa. the gen 2 busa and gix 750/600 of similar age run a different cam sensor , so anyone retrofitting can use the 07 gix 1000 sensor.

The 06 gix loom and 08 busa ecu work good on my gen 1 busa (setup with the gen 2 cam sensor and cover before i realised the gix would have been cheaper and easier)
the same loom and ecu do not work on my gix.
The 07 gix loom and ecu with busa .bin does work on my earlier gix when the cam sensor is fitted

So personally now i would not modify a 06 gix loom to use a busa ecu, to use the busa ecu on a busa get a busa loom .. and to get the same functionality on a gix get the gix ecu and loom and use the busa .bin .
posted similar on the 1000 section .




Last night I finished the following
orginal bike 06-07 gsxr 750 with turbo
-wired with a 08-09 gsxr 750 wiring harness
-running a 07-08 gsxr 1000 ecu
- running 08busa ecu editor, flashed with 08 Busa bin with 08-09 750 ign, fuel maps pasted and reflashed.

It fucking started and purred like a fucking champ!!!!

I am having problems with engine data. It says com port is not setup, however I was able to flash at least 3 times no problem.
I also would like to know e actly how people are wiring in their wideband dirrectly to the stock o2 harness wiring.
Thank you will post video later.

Offline sportbikeryder

  • OFF TOPIC
  • Universal Post Whore
  • **********
  • Posts: 7345
  • Gender: Male
Re: ecueditor.com for K7- gixxers
« Reply #82 on: October 10, 2011, 12:51:43 PM »
Cool  :tu:

What cam sensor are you using?
Any day on a motorcycle like this that ends just needing parts and labor is a good day.
4.82, 158.67mph 1/8th mile 7.350, 200.32mph 1/4 mile Riding

4.392, 176.79mph 1/8th mile  6.610, 228.15mph 1/4 mile Tuning

Offline gsx-rboy750

  • Authorized Shop
  • Post Master
  • **
  • Posts: 1721
  • Ok. So sometime I can be a little full of myself.
Re: ecueditor.com for K7- gixxers
« Reply #83 on: October 10, 2011, 01:53:30 PM »
Cool  :tu:

What cam sensor are you using?


Stock 06-07 gsxr 750
« Last Edit: October 10, 2011, 02:44:58 PM by gsx-rboy750 »

Offline Oz Booster

  • Site Donor
  • Mad Post Whore
  • *
  • Posts: 3968
  • aka Maj T
Re: ecueditor.com for K7- gixxers
« Reply #84 on: October 10, 2011, 05:32:35 PM »
 :D  Very nice ,
Wideband is powered /gnd independantly , not through the std o2 connector , but the wideband 0-5v output goes to the white /gn in that connector
i tried using the power from the std connector and it didn't seem to get enough current for the heater circuit to work properly , now trigger a relay parralling the fuel pump circuit (wideband hogs power if your key on fiddling with stuff )
Official Site Donor

Offline gsx-rboy750

  • Authorized Shop
  • Post Master
  • **
  • Posts: 1721
  • Ok. So sometime I can be a little full of myself.
Re: ecueditor.com for K7- gixxers
« Reply #85 on: October 10, 2011, 08:15:51 PM »
:D  Very nice ,
Wideband is powered /gnd independantly , not through the std o2 connector , but the wideband 0-5v output goes to the white /gn in that connector
i tried using the power from the std connector and it didn't seem to get enough current for the heater circuit to work properly , now trigger a relay parralling the fuel pump circuit (wideband hogs power if your key on fiddling with stuff )

thanks
but, when I got home I figured my com port was set up wrong.
So I finally got engine data to work and I THINK I SPOKE TOO SOON
my IAP looks strange.
I will have to get the wide band and on a dyno asap.

Offline ruckusman

  • New User!
  • *
  • Posts: 1
  • Enthusiast
Re: ecueditor.com for K7- gixxers
« Reply #86 on: July 13, 2022, 03:35:17 AM »
Update
07 gix 1000 cam sensor interchanges with the earlier sensors for fit , and gen 1 busa. the gen 2 busa and gix 750/600 of similar age run a different cam sensor , so anyone retrofitting can use the 07 gix 1000 sensor.

The 06 gix loom and 08 busa ecu work good on my gen 1 busa (setup with the gen 2 cam sensor and cover before i realised the gix would have been cheaper and easier)
the same loom and ecu do not work on my gix.
The 07 gix loom and ecu with busa .bin does work on my earlier gix when the cam sensor is fitted

So personally now i would not modify a 06 gix loom to use a busa ecu, to use the busa ecu on a busa get a busa loom .. and to get the same functionality on a gix get the gix ecu and loom and use the busa .bin .
posted similar on the 1000 section .

I know this is an ancient thread but with the ECU hacking forum and documentation gone I'm on a quest...
 
I'm very interested in any details you may recall about this.

For instance, do you know/remember the offset of the cam trigger pin in respect of BDC/TDC?

I haven't yet cross referenced pin assignments on both Busa and Gix 1K ECU/loom pins, are the pin assignments them same between them?

 OR

If the pin assignments aren't the same, do the Gix ECU pin assignments change to those of the BUSA ECU pin assignments when the BUSA  bin is flashed to the Gix ECU?